Jump to content

Recommended Posts

Salut ! Un énorme merci pour ce tuto qui a parfaitement fonctionner pour moi sur mon DS216play !

J'aimerai que le script démarre en même temps que mon synology (lors des coupures de courant), tu connaîtrais un tuto pour faire ça ?

Share this post


Link to post
Share on other sites

Salut :)

 

Tu crées un nouveau fichier /etc/init.d/JDownloader avec le script de démarrage à l'intérieur (en mode root) :

#!/bin/bash

screen

cd /volume1/jd
./start.sh

 

Tu rends ce script exécutable :

sudo chmod +x /etc/init.d/JDownloader

 

Et tu indiques à ta distribution de le lancer à son démarrage :

sudo update-rc.d JDownloader defaults

 

 

Normalement ça devrait fonctionner :)

Edited by Soulalex

Share this post


Link to post
Share on other sites

Je suis tout newbie sur le sujet :D Alors d'avance désolé pour mes questions bas niveau :

- Crée un fichier c'est-à-dire ? je le crée avec bloc note et j'entre ce texte ; 

#!/bin/bash

screen

cd /volume1/jd
./start.sh

?

Je suis sous windows, comment acceder à ce dossier : /etc/init.d/ : par le mode ssh de putty ou via le réseau windows (sachant que via le réseau je ne vois pour le moment que mes dossiers partagés ? Je viens de tester via putty avec la commande "cd etc/init.d" il ne trouve pas ce dossier... A moi qu'il faille que je le creé ?

Encore désolé pour mes questions idiotes, mais je débute sur ce language (même si il me rappel vaguement mon époque DOS...)

Merci d'avance en tout cas !

 

Share this post


Link to post
Share on other sites

Salut,

Il n'y a pas de questions bêtes ^^

 

Donc tu te connectes en SSH à ton serveur à l'aide de Putty (en mode root) et tu vas dans le dossier /etc/init.d/ :

cd /etc/init.d/

 

Ensuite, tu crées un nouveau fichier nommé JDownloader à l'aide de vi :

vi JDownloader

 

Une fenêtre de texte s'ouvre, tu appuies sur la touche "i" de ton clavier et tu saisies le script de démarrage :

#!/bin/bash

screen

cd /volume1/jd
./start.sh

 

Pour quitter et enregistrer : appuie sur "ECHAP" et entre ":wq" puis "ENTRER".

 

Tu rends ce script exécutable :

sudo chmod +x /etc/init.d/JDownloader

 

Et tu indiques à ta distribution de le lancer à son démarrage :

sudo update-rc.d JDownloader defaults

 

Voilà, en espérant avoir répondu à toutes tes questions :)

 

Bonne journée :)

Share this post


Link to post
Share on other sites

Merci pour tes explications je comprend déjà mieux :)

Je coince dés le départ car quand je fais dir je vois bien le dossier etc, mais à l'interieur de ce dossier je n'ai pas de dossier init.d mais juste un dossier init. Faut il que je crée ce dossier init.d ? ou je crée le fichier dont tu parles dans le dossier init ?

Merci pour ton temps :)

Share this post


Link to post
Share on other sites

Bonjour,

 

D'après ce que j'ai lu sur internet, il faut bien placer le script de démarrage dans le dossier /opt/etc/init.d/ (sur d'autres système linux, comme Debian, il faut mettre le script dans /etc/init.d/)

 

J'ai aussi refait le script de démarrage (regarde s'il fonctionne sinon utilise l'ancien ^^) :

#!/bin/bash

case "$1" in
	start)
		echo "Starting JDownloader..."
		loadproc /volume1/jd/start.sh
		;;
	stop)
		echo "Stopping JDownloader ..."
		killproc /volume1/jd/start.sh
		;;
	reload)
		echo "Reloading JDownloader..."
		killall -HUP JDownloader
		;;
	restart)
		$0 stop
		sleep 1
		$0 start
		;;
	status)
		statusproc /volume1/jd/start.sh
		;;
	*)
		echo "Usage: $0 {start|stop|reload|restart|status}"
		exit 1
		;;
esac

 

 

Bonne journée:)

Share this post


Link to post
Share on other sites

Bonjour,

 

j'ai essayé de suivre le tutoriel d'Oxodao mais je suis un gros noob en terme de NAS et de SSH.

Je suis arrivé à l'étape où il faut installer un bootstrap. Ayant un DS415+ j'ai fait une recherche sur internet et ça m'a mené ici :

https://forum.synology.com/enu/viewtopic.php?t=94291

J'ai suivi les instructions de Lithium_Grim dans son post du 17 mai 2015 sauf qu'après avoir modifié et sauvé le profil du root, j'ai voulu rentrer dedans pour vérifier que la manip avait bien fonctionné et là j'ai appuyé sur des touches, ça a marqué des messages du genre "delete line" et je pense avoir supprimer des choses importantes car depuis je ne peux plus me logger en root via putty :(

Le syno reste accessible via le réseau et via l'interface web mais plus via putty (il écrit -ash: hostname: not found).

Est-ce que quelqu'un aurait une idée de la connerie que je viens de faire et comment corriger le tir si c'est possible ?

 

Merci d'avance

Edited by Bulgrozz

Share this post


Link to post
Share on other sites

Bonjour,

 

Ce n'est pas vraiment le bon sujet pour parler de ça...

N'ayant pas de connaissances dans les NAS, je ne pourrais malheureusement pas t'aider. Maintenant, si tu peux accéder à l'interface d'administration web, essaye de regarder s'il n'existe pas une application "terminal" qui te permettra d'accéder à ton NAS en mode root.

 

Bonne chance :)

Share this post


Link to post
Share on other sites

Merci pour ce super tuto. Ça fonctionne super chez moi.

J'ai juste une petite question:

La décompression de fichiers compressés ne se fait pas toute seule après le téléchargement, même avec l'extension "Archive Extractor" activée. Avez-vous une idée pour rendre fonctionnelle cette extension? J'ai lu ici http://jdownloader.org/knowledge/wiki/addons/list/jdunrar que pour Linux, il fallait installer "unrar-nonfree". Je n'ai rien trouvé sur le sujet pour les NAS synology.

Merci.

 

Seb

Share this post


Link to post
Share on other sites

Quelqu'un arrive a décompresser les fichiers téléchargés? La configuration sous Windows fonctionnait sans problème, mais sous DSM ça ne fonctionne pas.

Share this post


Link to post
Share on other sites

Bonjour,

Merci pour ce tuto que j'ai utilisé pour installer jdownloader sur mon NAS DS211j. Il n'y a pas Java Manager sur le DS211j j'ai donc installé Java SE for embedded 8, tout fonctionne bien, je lance le fichier start.sh à partir du terminal de mon mac et jdownloader démarre correctement.

Je n'ai pas fait la partie bootstrap que je n'ai pas bien compris, mais quand je ferme ma fenêtre de terminal, jdownloader continue de tourner sur mon NAS donc tout va bien :)

Je vais sur mon compte myjdownloader je rajoute des links, jusque là ça va, mais quand je clique sur le bouton "Start Downloads" j'ai le message "JD running...", la vitesse de téléchargement reste à 0 b/s et après 5 secondes ça stoppe.

J'ai vérifié le pare-feu du NAS, j'ai mis le dossier de téléchargement en lect/ecrit pour tout le monde ... je n'ai plus d'idées. Je ne suis pas très callé sur linux, si quelqu'un a une suggestion à me faire, je veux bien tester

Merci de votre aide

Dav

Edited by dcdada

Share this post


Link to post
Share on other sites

bonjour,

désolé de ce retour tardif :rolleyes:

Je démarre bien jdownloader sur mon NAS. J'ouvre une fenetre de terminal sur le mac, je fais ensuite "nouvelle connection distante", je choisi SSH, je rentre l'IP du NAS etc ...

je vais dans /volume1/jd et je tape ./start.sh ;)

Concernant mon problème de téléchargements qui ne démarraient pas, si ça peut aider quelqu'un d'autre, ça marche quand je coche "auto start" au moment ou je rajoute les liens.

Donc je fais "add links" je colle les liens dans le champ prévu, je coche "auto start" en bas et je fais continuer ... et là mes téléchargements démarrent bien. Maintenant mes mkv sont téléchargés directement sur mon NAS, j'ai juste à démarrer PLEX et tout va bien :happysmile:

Edited by dcdada
  • Upvote 1

Share this post


Link to post
Share on other sites

Bonjour à tous,

Merci pour ce tuto super explicite, j'ai suivi toutes les étapes et ça marche du 1er coup !

Merci bien !

Edited by myryad

Share this post


Link to post
Share on other sites

Bonjour à tous,

Merci tout d'abord pour le tuto, je ne m'en suis pas sorti mais je ne désespère pas !

J'ai absolument pas compris le coup avec le bootstrap et screen (mais j'ai cru comprendre que c'était pas forcément le plus important)

A l'heure actuelle quand je lance mon fichier start.sh tout un tas de ligne apparait et je ne trouve pas mon NAS dans la liste des machines sur MyJdownloader...

Si vous pouviez me filer un coup de main ce serait top !

Merci d'avance !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...